Repocop reports by srpm

  rpm id test status message
libpfq-0.5.6-alt2.qa1.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpfq_exim.so but just /usr/lib64/libpfq_exim.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpfq_exim.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpfq_exim.so to \%files of libpfq-0.5.6-alt2.qa1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpfq_postfix1.so but just /usr/lib64/libpfq_postfix1.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpfq_postfix1.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpfq_postfix1.so to \%files of libpfq-0.5.6-alt2.qa1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpfq_postfix2.so but just /usr/lib64/libpfq_postfix2.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpfq_postfix2.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpfq_postfix2.so to \%files of libpfq-0.5.6-alt2.qa1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpfq_socket.so but just /usr/lib64/libpfq_socket.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpfq_socket.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpfq_socket.so to \%files of libpfq-0.5.6-alt2.qa1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpfqueue.so but just /usr/lib64/libpfqueue.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpfqueue.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpfqueue.so to \%files of libpfq-0.5.6-alt2.qa1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
pfqueue-0.5.6-alt2.qa1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/spfqueue
pfqueue-0.5.6-alt2.qa1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/spfqueue

generated by repocop at Wed Feb 19 04:50:33 2020