Repocop reports by srpm

  rpm id test status message
netxms-2.2.11-alt2.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/nxcsum
/usr/bin/nxlptest
/usr/bin/nxminfo
/usr/lib/libnxappc.a
/usr/share/netxms/radius.dict
/usr/share/netxms/sql/dbinit_db2.sql
/usr/share/netxms/sql/dbinit_mssql.sql
/usr/share/netxms/sql/dbinit_oracle.sql
/usr/share/netxms/sql/dbschema_db2.sql
/usr/share/netxms/sql/dbschema_mssql.sql
/usr/share/netxms/sql/dbschema_mysql.sql
/usr/share/netxms/sql/dbschema_oracle.sql
/usr/share/netxms/sql/dbschema_pgsql.sql
/usr/share/netxms/sql/dbschema_sqlite.sql
/var/lib/netxms/backgrounds/.keep
netxms-2.2.11-alt2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/nxcsum
/usr/bin/nxlptest
/usr/bin/nxminfo
/usr/lib64/libnxappc.a
/usr/share/netxms/radius.dict
/usr/share/netxms/sql/dbinit_db2.sql
/usr/share/netxms/sql/dbinit_mssql.sql
/usr/share/netxms/sql/dbinit_oracle.sql
/usr/share/netxms/sql/dbschema_db2.sql
/usr/share/netxms/sql/dbschema_mssql.sql
/usr/share/netxms/sql/dbschema_mysql.sql
/usr/share/netxms/sql/dbschema_oracle.sql
/usr/share/netxms/sql/dbschema_pgsql.sql
/usr/share/netxms/sql/dbschema_sqlite.sql
/var/lib/netxms/backgrounds/.keep
netxms-agent-2.2.11-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libappagent.so but just /usr/lib64/libappagent.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libappagent.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libappagent.so to \%files of netxms-agent-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxagent.so but just /usr/lib64/libnxagent.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxagent.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxagent.so to \%files of netxms-agent-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
netxms-agent-2.2.11-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/nxagentd: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
netxms-client-2.2.11-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxclient.so but just /usr/lib64/libnxclient.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxclient.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxclient.so to \%files of netxms-client-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
netxms-common-2.2.11-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnetxms.so but just /usr/lib64/libnetxms.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnetxms.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnetxms.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxdb.so but just /usr/lib64/libnxdb.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxdb.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxdb.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxjansson.so but just /usr/lib64/libnxjansson.so.4.6.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxjansson.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxjansson.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxlp.so but just /usr/lib64/libnxlp.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxlp.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxlp.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxsnmp.so but just /usr/lib64/libnxsnmp.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxsnmp.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxsnmp.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxtre.so but just /usr/lib64/libnxtre.so.5.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxtre.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxtre.so to \%files of netxms-common-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
netxms-server-2.2.11-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxcc.so but just /usr/lib64/libnxcc.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxcc.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxcc.so to \%files of netxms-server-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxcore.so but just /usr/lib64/libnxcore.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxcore.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxcore.so to \%files of netxms-server-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxsl.so but just /usr/lib64/libnxsl.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxsl.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxsl.so to \%files of netxms-server-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnxsrv.so but just /usr/lib64/libnxsrv.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libnxsrv.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnxsrv.so to \%files of netxms-server-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libstrophe.so but just /usr/lib64/libstrophe.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libstrophe.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libstrophe.so to \%files of netxms-server-2.2.11-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
netxms-server-2.2.11-alt2.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
netxms-server-2.2.11-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/netxmsd: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
netxms-server-2.2.11-alt2.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/lib64/libstrophe.so is different from the same symlink in the package libstrophe-devel-0.9.3-alt1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.

generated by repocop at Fri Jul 10 05:32:25 2020