Repocop reports by srpm

  rpm id test status message
mozldap-6.0.7-alt5.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libldap60.so but just /usr/lib64/libldap60.so.6.0.7. According to SharedLibs Policy Draft, symlink /usr/lib64/libldap60.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libldap60.so to \%files of mozldap-6.0.7-alt5.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libldif60.so but just /usr/lib64/libldif60.so.6.0.7. According to SharedLibs Policy Draft, symlink /usr/lib64/libldif60.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libldif60.so to \%files of mozldap-6.0.7-alt5.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libprldap60.so but just /usr/lib64/libprldap60.so.6.0.7. According to SharedLibs Policy Draft, symlink /usr/lib64/libprldap60.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libprldap60.so to \%files of mozldap-6.0.7-alt5.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libssldap60.so but just /usr/lib64/libssldap60.so.6.0.7. According to SharedLibs Policy Draft, symlink /usr/lib64/libssldap60.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libssldap60.so to \%files of mozldap-6.0.7-alt5.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
mozldap-6.0.7-alt5.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs

generated by repocop at Fri Feb 28 05:38:39 2020