Repocop reports by srpm

  rpm id test status message
mono-5.20.1.19-alt6.src altlinux-policy-obsolete-buildreq warn Build dependency on rpm-build-ubt is obsolete and should be dropped to get rid of rpm-build-ubt package.
mono-5.20.1.19-alt6.src beehive-log-non-strict-dependency-i586 info mono-winfx: non-strict dependency on mono-devel
mono-winfx: non-strict dependency on mono-extras
mono-reactive-winforms: non-strict dependency on mono-winfx
mono-dyndata: non-strict dependency on mono-mvc
mono-mvc: non-strict dependency on mono-devel
mono-mvc: non-strict dependency on mono-extras
mono-mvc: non-strict dependency on mono-winforms
mono-mvc: non-strict dependency on mono-wcf
mono-wcf: non-strict dependency on mono-mvc
mono-mvc: non-strict dependency on mono-web
mono-mvc: non-strict dependency on mono-data
mono-dyndata: non-strict dependency on mono-devel
mono-dyndata: non-strict dependency on mono-web
mono-dyndata: non-strict dependency on mono-data
mono-locale-extras: non-strict dependency on mono-devel
mono-extras: non-strict dependency on mono-devel
mono-reactive: non-strict dependency on mono-devel
mono-reactive-winforms: non-strict dependency on mono-devel
mono-winforms: non-strict dependency on mono-devel
mono-wcf: non-strict dependency on mono-devel
mono-web: non-strict dependency on mono-devel
mono-data: non-strict dependency on mono-devel
mono-data-sqlite: non-strict dependency on mono-devel
mono-data-oracle: non-strict dependency on mono-devel
mono-monodoc: non-strict dependency on mono-devel
mono-nunit: non-strict dependency on mono-devel
mono-extras: non-strict dependency on mono-winforms
mono-wcf: non-strict dependency on mono-extras
mono-extras: non-strict dependency on mono-data
mono-reactive-winforms: non-strict dependency on mono-winforms
mono-winforms: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-winforms
mono-winforms: non-strict dependency on mono-data
mono-wcf: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-wcf
mono-wcf: non-strict dependency on mono-data
mono-data: non-strict dependency on mono-wcf
mono-web: non-strict dependency on mono-data
mono-data: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-data-sqlite
mono-nunit: non-strict dependency on mono-web
mono-data-sqlite: non-strict dependency on mono-data
mono-data-oracle: non-strict dependency on mono-data
mono-5.20.1.19-alt6.src beehive-log-non-strict-dependency-x86_64 info mono-winfx: non-strict dependency on mono-devel
mono-winfx: non-strict dependency on mono-extras
mono-reactive-winforms: non-strict dependency on mono-winfx
mono-dyndata: non-strict dependency on mono-mvc
mono-mvc: non-strict dependency on mono-devel
mono-mvc: non-strict dependency on mono-extras
mono-mvc: non-strict dependency on mono-winforms
mono-mvc: non-strict dependency on mono-wcf
mono-wcf: non-strict dependency on mono-mvc
mono-mvc: non-strict dependency on mono-web
mono-mvc: non-strict dependency on mono-data
mono-dyndata: non-strict dependency on mono-devel
mono-dyndata: non-strict dependency on mono-web
mono-dyndata: non-strict dependency on mono-data
mono-locale-extras: non-strict dependency on mono-devel
mono-extras: non-strict dependency on mono-devel
mono-reactive: non-strict dependency on mono-devel
mono-reactive-winforms: non-strict dependency on mono-devel
mono-winforms: non-strict dependency on mono-devel
mono-wcf: non-strict dependency on mono-devel
mono-web: non-strict dependency on mono-devel
mono-data: non-strict dependency on mono-devel
mono-data-sqlite: non-strict dependency on mono-devel
mono-data-oracle: non-strict dependency on mono-devel
mono-monodoc: non-strict dependency on mono-devel
mono-nunit: non-strict dependency on mono-devel
mono-extras: non-strict dependency on mono-winforms
mono-wcf: non-strict dependency on mono-extras
mono-extras: non-strict dependency on mono-data
mono-reactive-winforms: non-strict dependency on mono-winforms
mono-winforms: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-winforms
mono-winforms: non-strict dependency on mono-data
mono-wcf: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-wcf
mono-wcf: non-strict dependency on mono-data
mono-data: non-strict dependency on mono-wcf
mono-web: non-strict dependency on mono-data
mono-data: non-strict dependency on mono-web
mono-web: non-strict dependency on mono-data-sqlite
mono-nunit: non-strict dependency on mono-web
mono-data-sqlite: non-strict dependency on mono-data
mono-data-oracle: non-strict dependency on mono-data
mono-core-5.20.1.19-alt6.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmono-native.so but just /usr/lib64/libmono-native.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmono-native.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmono-native.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmono-profiler-aot.so but just /usr/lib64/libmono-profiler-aot.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmono-profiler-aot.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmono-profiler-aot.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmono-profiler-coverage.so but just /usr/lib64/libmono-profiler-coverage.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmono-profiler-coverage.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmono-profiler-coverage.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmono-profiler-log.so but just /usr/lib64/libmono-profiler-log.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmono-profiler-log.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmono-profiler-log.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmonoboehm-2.0.so but just /usr/lib64/libmonoboehm-2.0.so.1.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmonoboehm-2.0.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmonoboehm-2.0.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmonosgen-2.0.so but just /usr/lib64/libmonosgen-2.0.so.1.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmonosgen-2.0.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmonosgen-2.0.so to \%files of mono-core-5.20.1.19-alt6.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
mono-core-5.20.1.19-alt6.x86_64 bin-permissions info not executable file /usr/bin/mono-gdb.py
not executable file /usr/bin/mono-sgen-gdb.py
mono-core-5.20.1.19-alt6.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/csc conflicts with the package chicken-5.2.0-alt1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
mono-core-5.20.1.19-alt6.x86_64 uncompressed-manpages info Package contains uncompressed manual pages.
mono-devel-5.20.1.19-alt6.x86_64 library-pkgnames-static warn package contains static library which has the same name as a shared library in the repository, but neither package name ends with -devel-static according to http://altlinux.org/Drafts/SharedLibs nor the package explicitly conflicts with the package with .so library
mono-devel-5.20.1.19-alt6.x86_64 uncompressed-manpages info Package contains uncompressed manual pages.
mono-monodoc-5.20.1.19-alt6.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.

generated by repocop at Wed Oct 28 05:05:51 2020