Repocop reports by srpm

  rpm id test Status message
apache2-base-2.4.29-alt1.S1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/sbin/a2dissite /usr/sbin/apachectl /usr/sbin/a2ensite /usr/sbin/a2chkconfig_list
apache2-base-2.4.29-alt1.S1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/share/man/man8/httpd.8.xz conflicts with the package bozohttpd-20170201-alt1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
apache2-base-2.4.29-alt1.S1.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
apache2-base-2.4.29-alt1.S1.x86_64 systemd-files-in-etc warn Systemd files Policy Draft violation: etc/tmpfiles.d/ is reserved for sysadmin overrides. Please, move /etc/tmpfiles.d/apache2.conf to \%_tmpfilesdir/.
apache2-devel-2.4.29-alt1.S1.x86_64 bin-permissions info not executable file /usr/sbin/envvars
apache2-htpasswd-2.4.29-alt1.S1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/htpasswd conflicts with the package mini_httpd-htpasswd-1.19-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
apache2-suexec-2.4.29-alt1.S1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/share/man/man8/suexec.8.xz conflicts with the package apache-common-1.3.42rusPL30.24-alt9.1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/sbin/suexec conflicts with the package apache-suexec-1.3.42rusPL30.24-alt9.1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.

generated by repocop at Tue Feb 13 06:37:52 2018