Repocop reports for by-leader mithraen

  rpm id test status message
anki2-2.0.50-alt1.noarch iconsdir experimental Please, move pixmaps from /usr/share/pixmaps to %_liconsdir, %_niconsdir, %_miconsdir according to their size. See http://www.altlinux.org/IconPathsPolicy.
asterisk-build-sounds-0.0.1-alt1.noarch missing-url info Missing Url: in a package.
asterisk-core-sounds-fr-alaw-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.alaw conflicts with the package asterisk-extra-sounds-fr-alaw-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-g722-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.g722 conflicts with the package asterisk-extra-sounds-fr-g722-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-g729-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.g729 conflicts with the package asterisk-extra-sounds-fr-g729-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-gsm-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.gsm conflicts with the package asterisk-extra-sounds-fr-gsm-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-siren14-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.siren14 conflicts with the package asterisk-extra-sounds-fr-siren14-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-siren7-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.siren7 conflicts with the package asterisk-extra-sounds-fr-siren7-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-sln16-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.sln16 conflicts with the package asterisk-extra-sounds-fr-sln16-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-ulaw-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.ulaw conflicts with the package asterisk-extra-sounds-fr-ulaw-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-core-sounds-fr-wav-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.wav conflicts with the package asterisk-extra-sounds-fr-wav-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-alaw-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.alaw conflicts with the package asterisk-core-sounds-fr-alaw-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-g722-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.g722 conflicts with the package asterisk-core-sounds-fr-g722-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-g729-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.g729 conflicts with the package asterisk-core-sounds-fr-g729-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-gsm-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.gsm conflicts with the package asterisk-core-sounds-fr-gsm-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-siren14-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.siren14 conflicts with the package asterisk-core-sounds-fr-siren14-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-siren7-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.siren7 conflicts with the package asterisk-core-sounds-fr-siren7-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-sln16-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.sln16 conflicts with the package asterisk-core-sounds-fr-sln16-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-ulaw-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.ulaw conflicts with the package asterisk-core-sounds-fr-ulaw-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk-extra-sounds-fr-wav-alt1.1-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/asterisk/sounds/fr/astcc-followed-by-the-pound-key.wav conflicts with the package asterisk-core-sounds-fr-wav-alt1.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
asterisk11-11.21.0-alt1.src unmet-dependency-build-missing-package fail build dependency libpw1.11-devel not found.
build dependency libwrap-devel not found.
asterisk11cert-11.6.cert13-alt1.src unmet-dependency-build-missing-package fail build dependency libpw1.11-devel not found.
build dependency libwrap-devel not found.
auto-fstrim-1.0-alt1.noarch missing-url info Missing Url: in a package.
basesystem-ve-4.0.1-alt1.noarch missing-url info Missing Url: in a package.
dahdi-2.10.2-alt2.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
dahdi-tools-2.10.2-alt2.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/etc/bash_completion.d/dahdi
dahdi-tools-2.10.2-alt2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/etc/bash_completion.d/dahdi
fake_remount_rw-0.0.1-alt1.noarch missing-url info Missing Url: in a package.
fuse-2.9.7-alt3.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/etc/init.d/fuse
fuse-2.9.7-alt3.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/etc/init.d/fuse
fuse-encfs-1.9.4-alt2.1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/bin/encfssh
fuse3-3.1.0-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/udev/rules.d/99-fuse3.rules
fuse3-3.1.0-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/udev/rules.d/99-fuse3.rules
ghc7.6.1-full-0.0.1-alt1.noarch missing-url info Missing Url: in a package.
ghc7.6.1-gtk-0.12.4-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
ghc7.6.1-openglraw-1.3.0.0-alt2.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
gtkwave-3.3.95-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/share/icons/hicolor/scalable/apps/gtkwave.svg
gtkwave-3.3.95-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/icons/hicolor/scalable/apps/gtkwave.svg
haskell-filetrigger-0.0.5-alt2.noarch missing-url info Missing Url: in a package.
iaxmodem-1.2.0-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
iaxmodem-1.2.0-alt1.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
interactivesystem-ve-4.0.1-alt1.noarch missing-url info Missing Url: in a package.
libresample-devel-0.1.3-alt5.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/lib64/libresample.so is different from the same symlink in the package libpjsip-devel-2.8-alt1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
libunixODBC2-2.3.4-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libodbcmyS.so but just /usr/lib64/libodbcmyS.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libodbcmyS.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libodbcmyS.so to \%files of libunixODBC2-2.3.4-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libodbcpsql.so but just /usr/lib64/libodbcpsql.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libodbcpsql.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libodbcpsql.so to \%files of libunixODBC2-2.3.4-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libodbcpsqlS.so but just /usr/lib64/libodbcpsqlS.so.2.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libodbcpsqlS.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libodbcpsqlS.so to \%files of libunixODBC2-2.3.4-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
mcron-1.1.1-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/crontab
/usr/sbin/cron
/usr/share/man/man1/crontab.1.xz
/usr/share/man/man8/cron.8.xz
mcron-1.1.1-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/bin/crontab
/usr/sbin/cron
/usr/share/man/man1/crontab.1.xz
/usr/share/man/man8/cron.8.xz
mithraen-scanutils-0.5-alt1.noarch freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/mithraen-scanutils.desktop: hint: value item "RasterGraphics" in key "Categories" in group "Desktop Entry" can be extended with another category among the following categories: Graphics;2DGraphics
nginx-1.14.0-alt3.x86_64 init-lsb warn /etc/rc.d/init.d/nginx: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
nginx-1.14.0-alt3.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
ossp-1.3.2-alt10.x86_64 init-lsb warn /etc/rc.d/init.d/osspd: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
ppp-2.4.7-alt5.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
priconfig-0.1-alt2.noarch missing-url info Missing Url: in a package.
privoxy-3.0.26-alt1.x86_64 init-lsb warn /etc/rc.d/init.d/privoxy: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
proguard-gui-5.3.3-alt1.noarch freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/proguard.desktop: warning: value "Java class file shrinker, optimizer, obfuscator and preverifier" for key "Comment" in group "Desktop Entry" looks redundant with value "Java class file shrinker, optimizer, obfuscator and preverifier" of key "GenericName"
sphinxbase-0.8-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/libsphinxad.a
/usr/lib/libsphinxbase.a
/usr/lib/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/sphinxbase.so
sphinxbase-0.8-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/libsphinxad.a
/usr/lib64/libsphinxbase.a
/usr/lib64/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/PKG-INFO
/usr/lib64/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/SOURCES.txt
/usr/lib64/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/dependency_links.txt
/usr/lib64/python2.7/site-packages/SphinxBase-0.8-py2.7.egg-info/top_level.txt
/usr/lib64/python2.7/site-packages/sphinxbase.so
sqlite-2.8.17-alt2.3.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/tcl/libtclsqlite.a
/usr/lib/tcl/libtclsqlite.la
sqlite-2.8.17-alt2.3.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/tcl/libtclsqlite.a
/usr/lib64/tcl/libtclsqlite.la
syncthing-inotify-0.8-alt1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
toxcore-bootstrapd-0.1.11-alt2.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
vzautolimit-0.01-alt3.noarch missing-url info Missing Url: in a package.
wanpipe-7.0.5-alt1.src unmet-dependency-build-missing-package fail build dependency kernel-headers-dahdi-ovz-el not found.
wanpipe-7.0.5-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
wanpipe-7.0.5-alt1.x86_64 init-condrestart fail /etc/rc.d/init.d/wanrouter: missing condrestart target. ERROR: alt-specific script %_sbindir/post_service (used in your %post_service macro) depends on condrestart. Please, fix./etc/rc.d/init.d/wanrouter: missing condstop target. ERROR: alt-specific script %_sbindir/preun_service (used in your %preun_service macro) depends on condstop. Please, fix.
wanpipe-7.0.5-alt1.x86_64 init-lsb fail /etc/rc.d/init.d/wanrouter: not systemd compatible: lsb init header missing and wanrouter.service is not present. See http://www.altlinux.org/Services_Policy for details.
xmonad-contrib-0.11.1-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
yate-6.1.0-alt1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/yate
yate-6.1.0-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
yate-6.1.0-alt1.x86_64 init-condrestart warn /etc/rc.d/init.d/yate: missing condstop target. Note: alt-specific script %_sbindir/preun_service (used in %preun_service macro) depends on condstop. It is wise to add condstop anyway.
yate-6.1.0-alt1.x86_64 init-lsb fail /etc/rc.d/init.d/yate: not systemd compatible: lsb init header missing and yate.service is not present. See http://www.altlinux.org/Services_Policy for details.
yate-qt4-6.1.0-alt1.x86_64 altlinux-policy-debian-menu-is-deprecated warn package contains deprecated /usr/lib/menu/ files. Please, convert to .desktop files
yate-qt4-6.1.0-alt1.x86_64 freedesktop-categories warn Menu-related Additional Categories (http://standards.freedesktop.org/menu-spec/latest/apa.html) not found in /usr/share/applications/yate-qt4.desktop. Please add it or report a bug against this test if you already have registered one (not including menu unrelated ones as Core or Qt).

generated by repocop at Mon Oct 22 04:16:54 2018