Repocop reports for by-leader lakostis

  rpm id test status message
NetworkManager-fortisslvpn-1.2.8-alt1.1.x86_64 file-in-usr-marked-as-conffile warn Files below /usr may not be marked as conffiles, since
/usr might be mounted read-only and thus, the local system
administrator would not have a chance to modify this configuration
file.
bitlbee-facebook-1.1.2-alt3.7682a35.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/bitlbee/facebook.la
bitlbee-facebook-1.1.2-alt3.7682a35.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/bitlbee/facebook.la
bluez-alsa-1.4.0-alt0.5.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/alsa-lib/libasound_module_ctl_bluealsa.a
/usr/lib/alsa-lib/libasound_module_ctl_bluealsa.la
/usr/lib/alsa-lib/libasound_module_pcm_bluealsa.a
/usr/lib/alsa-lib/libasound_module_pcm_bluealsa.la
bluez-alsa-1.4.0-alt0.5.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/alsa-lib/libasound_module_ctl_bluealsa.a
/usr/lib64/alsa-lib/libasound_module_ctl_bluealsa.la
/usr/lib64/alsa-lib/libasound_module_pcm_bluealsa.a
/usr/lib64/alsa-lib/libasound_module_pcm_bluealsa.la
bolt-0.8-alt0.1.g55918d9.x86_64 dbus-xml-not-in-devel info file /usr/share/dbus-1/interfaces/org.freedesktop.bolt.xml is not used in run time. Move it to the -devel subpackage.
clang7.0-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package clang9.0-9.0.1-alt2.x86_64, for example, /usr/bin/c-index-test (9 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/bin/clang is different from the same symlink in the package clang9.0-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-7.0.1-alt4.rel.x86_64 sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/x86_64/RPMS/clang7.0-7.0.1-alt4.rel.x86_64.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation
clang7.0-analyzer-7.0.1-alt4.rel.noarch rpm-filesystem-conflict-file-file warn There are file conflicts with the package clang9.0-analyzer-9.0.1-alt2.noarch, for example, /usr/bin/scan-build (7 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-debuginfo-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/lib/debug/usr/bin/clang++.debug is different from the same symlink in the package clang9.0-debuginfo-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
value of symlink /usr/lib/debug/usr/bin/clang-cl.debug is different from the same symlink in the package clang9.0-debuginfo-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
value of symlink /usr/lib/debug/usr/bin/clang-cpp.debug is different from the same symlink in the package clang9.0-debuginfo-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
value of symlink /usr/lib/debug/usr/bin/clang.debug is different from the same symlink in the package clang9.0-debuginfo-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-devel-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package clang9.0-devel-9.0.1-alt2.x86_64, for example, /usr/include/clang-c/Index.h (504 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-devel-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/lib64/libclang.so is different from the same symlink in the package clang9.0-devel-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-devel-static-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package clang9.0-devel-static-9.0.1-alt2.x86_64, for example, /usr/lib64/libclangARCMigrate.a (29 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-doc-7.0.1-alt4.rel.noarch rpm-filesystem-conflict-file-file warn There are file conflicts with the package clang9.0-doc-9.0.1-alt2.noarch, for example, /usr/share/doc/clang/html/AddressSanitizer.html (110 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
clang7.0-libs-7.0.1-alt4.rel.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
courier-authlib-0.66.4-alt0.3.1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/libexec/courier-authlib/makedatprog
/usr/share/man/man8/pw2userdb.8.xz
courier-authlib-0.66.4-alt0.3.1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/libexec/courier-authlib/makedatprog
/usr/share/man/man8/pw2userdb.8.xz
courier-authlib-0.66.4-alt0.3.1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/courier-authdaemon
courier-authlib-0.66.4-alt0.3.1.x86_64 init-lsb warn /etc/rc.d/init.d/courier-authdaemon: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
courier-maildrop-2.8.4-alt0.3.src beehive-log-non-strict-dependency-i586 info courier-maildrop: non-strict dependency on courier-maildrop-utils
courier-maildrop-2.8.4-alt0.3.src beehive-log-non-strict-dependency-x86_64 info courier-maildrop: non-strict dependency on courier-maildrop-utils
courier-unicode-1.4-alt0.1.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
firehol-3.1.5-alt1.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
gliv-1.9.7-alt3.e7b0afc.x86_64 freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/gliv.desktop: hint: value item "RasterGraphics" in key "Categories" in group "Desktop Entry" can be extended with another category among the following categories: Graphics;2DGraphics
gliv-1.9.7-alt3.e7b0afc.x86_64 iconsdir experimental Please, move pixmaps from /usr/share/pixmaps to %_liconsdir, %_niconsdir, %_miconsdir according to their size. See http://www.altlinux.org/IconPathsPolicy.
gnu-efi-3.0.5-3.0.5-alt0.1.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package gnu-efi-3.0r-3.0r-alt3.x86_64, for example, /usr/include/efi/efi.h (23 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
There are file conflicts with the package gnu-efi-3.0u-3.0u-alt4.x86_64, for example, /usr/include/efi/efi.h (21 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
gnustep-dbuskit-0.3.2-alt7.svn20140131.2.x86_64 big-changelog info Package contains big ChangeLog. Gzip it.
jabber-muc-0.8.81-alt0.1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
jabber-muc-0.8.81-alt0.1.x86_64 init-lsb fail /etc/rc.d/init.d/jabber-muc: not systemd compatible: lsb init header missing and jabber-muc.service is not present. See http://www.altlinux.org/Services_Policy for details.
jabber-muc-0.8.81-alt0.1.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
jabberd2-2.7.0-alt2.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/etc/init/jabberd-c2s.conf
/usr/etc/init/jabberd-router.conf
/usr/etc/init/jabberd-s2s.conf
/usr/etc/init/jabberd-sm.conf
/usr/libexec/jabberd2/jabberd
/usr/share/doc/jabberd2-2.7.0/db-setup.oracle
/usr/share/doc/jabberd2-2.7.0/migrate.pl
jabberd2-2.7.0-alt2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/etc/init/jabberd-c2s.conf
/usr/etc/init/jabberd-router.conf
/usr/etc/init/jabberd-s2s.conf
/usr/etc/init/jabberd-sm.conf
/usr/libexec/jabberd2/jabberd
/usr/share/doc/jabberd2-2.7.0/db-setup.oracle
/usr/share/doc/jabberd2-2.7.0/migrate.pl
jabberd2-2.7.0-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/jabberd2-router: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
jabberd2-c2s-2.7.0-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/jabberd2-c2s: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
jabberd2-s2s-2.7.0-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/jabberd2-s2s: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
jabberd2-sm-2.7.0-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/jabberd2-sm: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
libvulkan1-debuginfo-1.1.121-alt1.1.x86_64 buildroot fail found paths to buildroot: /usr/lib/debug/usr/lib64/libvulkan.so.1.1.121.debug: Binary file /usr/lib/debug/usr/lib64/libvulkan.so.1.1.121.debug matches
lld-7.0.1-alt4.rel.x86_64 rpm-package-is-obsoleted warn The package is obsoleted by the package lld9.0-9.0.1-alt2.x86_64, but is still alive and in the repository. Consider removing the package, or, if you want the package to be alive, ask the maintainer of lld9.0-9.0.1-alt2.x86_64 to remove Obsoletes: tag.
lld-devel-7.0.1-alt4.rel.x86_64 rpm-package-is-obsoleted warn The package is obsoleted by the package lld9.0-devel-9.0.1-alt2.x86_64, but is still alive and in the repository. Consider removing the package, or, if you want the package to be alive, ask the maintainer of lld9.0-devel-9.0.1-alt2.x86_64 to remove Obsoletes: tag.
lld-doc-7.0.1-alt4.rel.noarch rpm-package-is-obsoleted warn The package is obsoleted by the package lld9.0-doc-9.0.1-alt2.noarch, but is still alive and in the repository. Consider removing the package, or, if you want the package to be alive, ask the maintainer of lld9.0-doc-9.0.1-alt2.noarch to remove Obsoletes: tag.
llvm7.0-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package llvm9.0-9.0.1-alt2.x86_64, for example, /usr/bin/bugpoint (75 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
llvm7.0-7.0.1-alt4.rel.x86_64 sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/x86_64/RPMS/llvm7.0-7.0.1-alt4.rel.x86_64.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation
llvm7.0-devel-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package llvm9.0-devel-9.0.1-alt2.x86_64, for example, /usr/bin/llvm-config (1187 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
llvm7.0-devel-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-symlink-symlink warn value of symlink /usr/lib64/libLLVM.so is different from the same symlink in the package llvm9.0-devel-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
value of symlink /usr/lib64/libLTO.so is different from the same symlink in the package llvm9.0-devel-9.0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
llvm7.0-devel-static-7.0.1-alt4.rel.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package llvm9.0-devel-static-9.0.1-alt2.x86_64, for example, /usr/lib64/libLLVMAMDGPUAsmParser.a (88 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
llvm7.0-doc-7.0.1-alt4.rel.noarch rpm-filesystem-conflict-file-file warn There are file conflicts with the package llvm9.0-doc-9.0.1-alt2.noarch, for example, /usr/share/doc/llvm/html/AMDGPUOperandSyntax.html (261 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
llvm7.0-libs-7.0.1-alt4.rel.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
mailman-2.1.29.0.9.e227c-alt2.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
mailman-2.1.29.0.9.e227c-alt2.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
mailman-apache2-2.1.29.0.9.e227c-alt2.noarch altlinux-policy-obsolete-httpd2-reload info This package contains httpd2 restart/reload calls in its post/un scripts. But those calls are deprecated by httpd2.filetrigger that activates by files in /etc/httpd2/ or %_libdir/apache2/modules/. It should be safe to remove those calls and rely on the filetrigger instead.
milter-greylist-4.6.1-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
milter-greylist-4.6.1-alt1.x86_64 init-lsb fail /etc/rc.d/init.d/milter-greylist: not systemd compatible: lsb init header missing and milter-greylist.service is not present. See http://www.altlinux.org/Services_Policy for details.
openfortivpn-1.10.0-alt0.g320f95f.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/share/config.template
openfortivpn-1.10.0-alt0.g320f95f.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/config.template
pam-mysql-0.8.1-alt0.1.g4f76d51.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/lib/security/pam_mysql.la
pam-mysql-0.8.1-alt0.1.g4f76d51.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/lib64/security/pam_mysql.la
piper-0.2.900-alt0.3.git5f6ed20.noarch freedesktop-categories warn Menu-related Additional Categories (http://standards.freedesktop.org/menu-spec/latest/apa.html) not found in /usr/share/applications/org.freedesktop.Piper.desktop. Please add it or report a bug against this test if you already have registered one (not including menu unrelated ones as Core or Qt).
piper-0.2.900-alt0.3.git5f6ed20.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/share/locale/de/LC_MESSAGES/piper.mo
/usr/share/locale/hr/LC_MESSAGES/piper.mo
/usr/share/locale/nl/LC_MESSAGES/piper.mo
/usr/share/locale/pl/LC_MESSAGES/piper.mo
/usr/share/locale/sv/LC_MESSAGES/piper.mo
piper-0.2.900-alt0.3.git5f6ed20.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/locale/de/LC_MESSAGES/piper.mo
/usr/share/locale/hr/LC_MESSAGES/piper.mo
/usr/share/locale/nl/LC_MESSAGES/piper.mo
/usr/share/locale/pl/LC_MESSAGES/piper.mo
/usr/share/locale/sv/LC_MESSAGES/piper.mo
pypolicyd-spf-2.0.2-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/python3/site-packages/__pycache__/policydspfsupp.cpython-37.opt-1.pyc
/usr/lib/python3/site-packages/__pycache__/policydspfuser.cpython-37.opt-1.pyc
pypolicyd-spf-2.0.2-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/python3/site-packages/__pycache__/policydspfsupp.cpython-37.opt-1.pyc
/usr/lib/python3/site-packages/__pycache__/policydspfuser.cpython-37.opt-1.pyc
python-module-commonmark-0.8.1-alt0.1.noarch rpm-filesystem-conflict-file-file warn File /usr/bin/cmark conflicts with the package cmark-0.29.0-alt1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
rbldnsd-0.998-alt2.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/rbldnsd
rbldnsd-0.998-alt2.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
smbios-utils-2.4.1-alt2.x86_64 sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/x86_64/RPMS/smbios-utils-2.4.1-alt2.x86_64.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation /ALT/Sisyphus/files/x86_64/RPMS/smbios-utils-2.4.1-alt2.x86_64.rpm: license not found in '/usr/share/license' directory: OSL /ALT/Sisyphus/files/x86_64/RPMS/smbios-utils-2.4.1-alt2.x86_64.rpm: license not found in '/usr/share/license' directory: 2.1
vkd3d-1.1-alt0.3.gbe4ca96.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/libvkd3d-shader.a
/usr/lib/libvkd3d-utils.a
/usr/lib/libvkd3d.a
vkd3d-1.1-alt0.3.gbe4ca96.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/libvkd3d-shader.a
/usr/lib64/libvkd3d-utils.a
/usr/lib64/libvkd3d.a
vulkan-tools-debuginfo-1.1.121-alt1.1.x86_64 buildroot fail found paths to buildroot: /usr/lib/debug/usr/bin/vulkaninfo.debug: Binary file /usr/lib/debug/usr/bin/vulkaninfo.debug matches /usr/lib/debug/usr/bin/vkcube.debug: Binary file /usr/lib/debug/usr/bin/vkcube.debug matches /usr/lib/debug/usr/bin/vkcubepp.debug: Binary file /usr/lib/debug/usr/bin/vkcubepp.debug matches
vulkan-validation-layers-1.1.121-alt1.1.x86_64 buildroot fail found paths to buildroot: /usr/lib64/libVkLayer_utils.a: Binary file /usr/lib64/libVkLayer_utils.a matches
vulkan-validation-layers-debuginfo-1.1.121-alt1.1.x86_64 buildroot fail found paths to buildroot: /usr/lib/debug/usr/lib64/libVkLayer_stateless_validation.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_stateless_validation.so.debug matches /usr/lib/debug/usr/lib64/libVkLayer_thread_safety.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_thread_safety.so.debug matches /usr/lib/debug/usr/lib64/libVkLayer_khronos_validation.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_khronos_validation.so.debug matches /usr/lib/debug/usr/lib64/libVkLayer_object_lifetimes.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_object_lifetimes.so.debug matches /usr/lib/debug/usr/lib64/libVkLayer_unique_objects.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_unique_objects.so.debug matches /usr/lib/debug/usr/lib64/libVkLayer_core_validation.so.debug: Binary file /usr/lib/debug/usr/lib64/libVkLayer_core_validation.so.debug matches

generated by repocop at Mon Feb 24 04:29:12 2020