Repocop reports for by-leader imz

  rpm id test status message
hg-fast-export-160914-alt1.noarch bin-permissions info not executable file /usr/bin/hg-fast-export.py
not executable file /usr/bin/hg-reset.py
hg-fast-export-160914-alt1.noarch sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/noarch/RPMS/hg-fast-export-160914-alt1.noarch.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation /ALT/Sisyphus/files/noarch/RPMS/hg-fast-export-160914-alt1.noarch.rpm: The use of such a license name is ambiguous: GPL
initscripts-compat-fedora-9.72-alt1.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/functions-compat
initscripts-compat-fedora-9.72-alt1.noarch init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
owamp-server-3.5.0-alt2.x86_64 uncompressed-manpages info Package contains uncompressed manual pages.
prelink-0.4.4-alt3.x86_64 missing-url info Missing Url: in a package.
prelink-tools-0.4.4-alt3.x86_64 missing-url info Missing Url: in a package.
prelink-tools-debuginfo-0.4.4-alt3.x86_64 missing-url info Missing Url: in a package.
python-module-imagesize-1.1.0-alt1.noarch sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/noarch/RPMS/python-module-imagesize-1.1.0-alt1.noarch.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation
python-modules-unittest-2.7.17-alt4.x86_64 altlinux-python-test-is-packaged info /usr/lib64/python2.7/unittest/test/test_assertions.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_assertions.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_assertions.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_break.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_break.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_break.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_case.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_case.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_case.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_discovery.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_discovery.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_discovery.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_functiontestcase.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_functiontestcase.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_functiontestcase.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_loader.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_loader.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_loader.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_program.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_program.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_program.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_result.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_result.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_result.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_runner.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_runner.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_runner.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_setups.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_setups.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_setups.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_skipping.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_skipping.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_skipping.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_suite.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_suite.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib64/python2.7/unittest/test/test_suite.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
python-tools-idle-2.7.17-alt4.x86_64 altlinux-policy-debian-menu-is-deprecated warn package contains deprecated /usr/lib/menu/ files. Please, convert to .desktop files
python-tools-scripts-2.7.17-alt4.x86_64 altlinux-python-obsolete-buildreq-python-dev warn python-dev is obsolete according to Python Policy (http://www.altlinux.org/Python_Policy). Please, use BuildRequires: python-devel.
python3-tools-3.7.4-alt2.x86_64 altlinux-python-python3-requires-python warn python3 package requires python-base.
python3-tools-3.7.4-alt2.x86_64 sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/x86_64/RPMS/python3-tools-3.7.4-alt2.x86_64.rpm: forbidden requires: python-base sisyphus_check: check-deps ERROR: package dependencies violation
rpm-build-python-0.38.0-alt1.src altlinux-python-obsolete-buildreq-python-dev warn python-dev is obsolete according to Python Policy (http://www.altlinux.org/Python_Policy). Please, use BuildRequires: python-devel.
rpmquery-strictdep-1-alt1.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/bin/rpmquery-strictdep
tests-for-installed-python3-pkgs-0.1.13.1-alt2.noarch missing-url info Missing Url: in a package.
verlihub-plugin-python-1.1-alt3.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libpython_pi.so but just /usr/lib64/libpython_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libpython_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libpython_pi.so to \%files of verlihub-plugin-python-1.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libvh_python_wrapper.so but just /usr/lib64/libvh_python_wrapper.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libvh_python_wrapper.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libvh_python_wrapper.so to \%files of verlihub-plugin-python-1.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
verlihub-plugins-0.1-alt3.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libchatroom_pi.so but just /usr/lib64/libchatroom_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libchatroom_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libchatroom_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libforbid_pi.so but just /usr/lib64/libforbid_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libforbid_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libforbid_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libiplog_pi.so but just /usr/lib64/libiplog_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libiplog_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libiplog_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libisp_pi.so but just /usr/lib64/libisp_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libisp_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libisp_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libmessanger_pi.so but just /usr/lib64/libmessanger_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libmessanger_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libmessanger_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libreplace_pi.so but just /usr/lib64/libreplace_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libreplace_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libreplace_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libstats_pi.so but just /usr/lib64/libstats_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libstats_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libstats_pi.so to \%files of verlihub-plugins-0.1-alt3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
verlihub-plugins-lua51-1.8.1-alt1.qa3.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/liblua_pi.so but just /usr/lib64/liblua_pi.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/liblua_pi.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/liblua_pi.so to \%files of verlihub-plugins-lua51-1.8.1-alt1.qa3.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.

generated by repocop at Mon Feb 24 04:29:12 2020