Repocop reports by acl

  packager rpm id test Status message
aris gst-plugins-bad1.0-1.12.4-alt3.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
ender subversion-javahl-1.9.2-alt3.2.1.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libsvnjavahl-1.so but just /usr/lib64/libsvnjavahl-1.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libsvnjavahl-1.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libsvnjavahl-1.so to \%files of subversion-javahl-1.9.2-alt3.2.1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
ender subversion-server-dav-1.9.2-alt3.2.1.x86_64 altlinux-policy-obsolete-httpd2-reload info This package contains httpd2 restart/reload calls in its post/un scripts. But those calls are deprecated by httpd2.filetrigger that activates by files in /etc/httpd2/ or %_libdir/apache2/modules/. It should be safe to remove those calls and rely on the filetrigger instead.
ender subversion-server-standalone-1.9.2-alt3.2.1.noarch init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
ender subversion-server-standalone-1.9.2-alt3.2.1.noarch init-lsb fail /etc/rc.d/init.d/svnserve: not systemd compatible: lsb init header missing and svnserve.service is not present. See http://www.altlinux.org/Services_Policy for details.
lav dia-0.97.4-alt0.1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
lav dia-0.97.4-alt0.1.x86_64 freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/dia.desktop: hint: value item "GNOME" in key "Categories" in group "Desktop Entry" can be extended with another category among the following categories: GTK
lav dia-0.97.4-alt0.1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/dia conflicts with the package tklib-0.6-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
mike alsa-oss-1.0.28-alt1.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libalsatoss.so but just /usr/lib64/libalsatoss.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libalsatoss.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libalsatoss.so to \%files of alsa-oss-1.0.28-alt1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libaoss.so but just /usr/lib64/libaoss.so.0.0.0. According to SharedLibs Policy Draft, symlink /usr/lib64/libaoss.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libaoss.so to \%files of alsa-oss-1.0.28-alt1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
mike ifplugd-0.28-alt4.qa1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
mike ifplugd-0.28-alt4.qa1.x86_64 init-lsb fail /etc/rc.d/init.d/ifplugd: not systemd compatible: lsb init header missing and ifplugd.service is not present. See http://www.altlinux.org/Services_Policy for details.
sem xorg-apps-7.8-alt5.x86_64 missing-url info Missing Url: in a package.
sem xorg-drv-input-7.8-alt5.x86_64 missing-url info Missing Url: in a package.
sem xorg-drv-video-7.8-alt5.x86_64 missing-url info Missing Url: in a package.
sem xorg-proto-devel-7.8-alt5.x86_64 missing-url info Missing Url: in a package.
sem xorg-utils-7.8-alt5.x86_64 missing-url info Missing Url: in a package.
shaba pidgin-2.12.0-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek acpid-2.0.22-alt1.x86_64 init-lsb warn /etc/rc.d/init.d/acpid: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
shrek bluez-5.48-alt2.x86_64 init-lsb warn /etc/rc.d/init.d/bluetoothd: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
shrek compiz-0.9.13.1-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek dlm-4.0.6-alt1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek evince-3.26.0-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek evince-3.26.0-alt1.x86_64 freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/evince.desktop: hint: value "GNOME;GTK;Office;Viewer;Graphics;2DGraphics;VectorGraphics;" for key "Categories" in group "Desktop Entry" contains more than one main category; application might appear more than once in the application menu
desktop-file-validate utility printed the following message(s): /usr/share/applications/evince-previewer.desktop: warning: value "Pregled prije ?tampe" for key "Comment[bs]" in group "Desktop Entry" looks redundant with value "Pregled prije ?tampe" of key "Name[bs]"
/usr/share/applications/evince-previewer.desktop: warning: value "Aper?u avant impression" for key "Comment[fr]" in group "Desktop Entry" looks redundant with value "Aper?u avant impression" of key "Name[fr]"
/usr/share/applications/evince-previewer.desktop: warning: value "Afdrukvoorbeeld" for key "Comment[nl]" in group "Desktop Entry" looks redundant with value "Afdrukvoorbeeld" of key "Name[nl]"
/usr/share/applications/evince-previewer.desktop: warning: value "Apercebut abans impression" for key "Comment[oc]" in group "Desktop Entry" looks redundant with value "Apercebut abans impression" of key "Name[oc]"
/usr/share/applications/evince-previewer.desktop: warning: value "?????????????????????" for key "Comment[th]" in group "Desktop Entry" looks redundant with value "?????????????????????" of key "Name[th]"
/usr/share/applications/evince-previewer.desktop: hint: value "GNOME;GTK;Office;Viewer;Graphics;2DGraphics;VectorGraphics;" for key "Categories" in group "Desktop Entry" contains more than one main category; application might appear more than once in the application menu
shrek fence-agents-alom-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-amt-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-apc-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-apc-snmp-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-bladecenter-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-brocade-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-cisco-mds-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-cisco-ucs-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-compute-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-docker-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-drac-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-drac5-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-eaton-snmp-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-emerson-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-eps-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-hds-cb-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-hpblade-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ibmblade-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ifmib-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ilo-moonshot-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ilo-mp-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ilo-ssh-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ilo2-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-intelmodular-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ipdu-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ipmilan-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-kdump-4.0.24-alt3.S1.x86_64 uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ldom-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-lpar-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-mpath-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-netio-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-ovh-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-pve-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-raritan-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-rcd-serial-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-rhevm-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-rsa-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-rsb-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-sanbox2-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-scsi-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-vbox-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-virsh-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-vmware-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-vmware-soap-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-wti-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-xenapi-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fence-agents-zvm-4.0.24-alt3.S1.noarch uncompressed-manpages info Package contains uncompressed manual pages.
shrek fonts-bitmap-100dpi-7.0.0-alt3.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/fonts/bitmap/75dpi/fonts.alias
/usr/share/fonts/bitmap/cyrillic/fonts.alias
/usr/share/fonts/bitmap/misc/fonts.alias
shrek fonts-bitmap-75dpi-7.0.0-alt4.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/fonts/bitmap/100dpi/fonts.alias
/usr/share/fonts/bitmap/cyrillic/fonts.alias
/usr/share/fonts/bitmap/misc/fonts.alias
shrek fonts-bitmap-cyrillic-2.3.1-alt7.noarch fonts.alias warn WARNING: /tmp/.private/repocop/repocop-run.Fer5pW2h/usr/share/fonts/bitmap/cyrillic/misc/fonts.alias:
glob -*-helvetica-bold-r-normal-*-*-120-*-*-*-*-koi8-r not found for alias variable
glob -*-helvetica-bold-r-normal-*-*-120-*-*-*-*-koi8-r not found for alias koi-variable
shrek fonts-bitmap-cyrillic-2.3.1-alt7.noarch missing-url info Missing Url: in a package.
shrek fonts-bitmap-misc-7.0.0-alt6.noarch fonts.alias warn WARNING: /tmp/.private/repocop/repocop-run.kCikyTFu/usr/share/fonts/bitmap/misc/fonts.alias:
glob -*-helvetica-bold-r-normal-*-*-120-*-*-*-*-iso8859-1 not found for alias variable
shrek fonts-bitmap-misc-7.0.0-alt6.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/fonts/bitmap/100dpi/fonts.alias
/usr/share/fonts/bitmap/75dpi/fonts.alias
/usr/share/fonts/bitmap/cyrillic/fonts.alias
shrek fonts-ttf-syriac-1.0-alt6.noarch missing-url info Missing Url: in a package.
shrek fonts-ttf-xorg-1.0.0-alt3.noarch altlinux-policy-rpm-group-should-be-ttf info RPM group should be 'System/Fonts/True type'.
shrek gimp-2.8.22-alt1.src altlinux-python-obsolete-buildreq-python-dev warn python-dev is obsolete according to Python Policy (http://www.altlinux.org/Python_Policy). Please, use BuildRequires: python-devel.
shrek gimp-2.8.22-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek gnome-icon-theme-tango-0.1-alt5.noarch missing-url info Missing Url: in a package.
shrek gnome-icon-theme-tango-0.1-alt5.noarch obsolete-call-in-post-gtk-update-icon-cache warn gtk-update-icon-cache call in post/postun is deprecated
shrek gobject-introspection-1.54.1-alt1.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
shrek gobject-introspection-devel-1.54.1-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek gst-plugins-base-0.10.36-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/gstreamer-0.10/libgstadder.la
/usr/lib64/gstreamer-0.10/libgstalsa.la
/usr/lib64/gstreamer-0.10/libgstapp.la
/usr/lib64/gstreamer-0.10/libgstaudioconvert.la
/usr/lib64/gstreamer-0.10/libgstaudiorate.la
/usr/lib64/gstreamer-0.10/libgstaudioresample.la
/usr/lib64/gstreamer-0.10/libgstaudiotestsrc.la
/usr/lib64/gstreamer-0.10/libgstcdparanoia.la
/usr/lib64/gstreamer-0.10/libgstdecodebin.la
/usr/lib64/gstreamer-0.10/libgstdecodebin2.la
/usr/lib64/gstreamer-0.10/libgstencodebin.la
/usr/lib64/gstreamer-0.10/libgstffmpegcolorspace.la
/usr/lib64/gstreamer-0.10/libgstgdp.la
/usr/lib64/gstreamer-0.10/libgstgio.la
/usr/lib64/gstreamer-0.10/libgstogg.la
/usr/lib64/gstreamer-0.10/libgstpango.la
/usr/lib64/gstreamer-0.10/libgstplaybin.la
/usr/lib64/gstreamer-0.10/libgstsubparse.la
/usr/lib64/gstreamer-0.10/libgsttcp.la
/usr/lib64/gstreamer-0.10/libgsttheora.la
/usr/lib64/gstreamer-0.10/libgsttypefindfunctions.la
/usr/lib64/gstreamer-0.10/libgstvideorate.la
/usr/lib64/gstreamer-0.10/libgstvideoscale.la
/usr/lib64/gstreamer-0.10/libgstvideotestsrc.la
/usr/lib64/gstreamer-0.10/libgstvolume.la
/usr/lib64/gstreamer-0.10/libgstvorbis.la
/usr/lib64/gstreamer-0.10/libgstximagesink.la
/usr/lib64/gstreamer-0.10/libgstxvimagesink.la
shrek gst-plugins-devel-0.10.36-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek gst-plugins-gl-0.10.2-alt1.qa1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/gstreamer-0.10/libgstopengl.la
shrek gst-plugins-gnonlin-0.10.16-alt1.qa1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/gstreamer-0.10/libgnl.la
shrek gutenprint-5.2.9-alt1.src beehive-log-dependency-needs-epoch-x86_64 info gutenprint: dependency on libgutenprint needs Epoch
gimp-plugin-gutenprint: dependency on gutenprint needs Epoch
gutenprint-foomatic: dependency on gutenprint needs Epoch
gutenprint-CUPS: dependency on gutenprint needs Epoch
libgutenprint-devel: dependency on libgutenprint needs Epoch
shrek gutenprint-5.2.9-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek gutenprint-CUPS-5.2.9-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek hibernate-script-2.0-alt3.qa1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/sbin/hibernate
shrek hibernate-script-2.0-alt3.qa1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
shrek hibernate-script-2.0-alt3.qa1.x86_64 init-lsb fail /etc/rc.d/init.d/hibernate-cleanup: not systemd compatible: lsb init header missing and hibernate-cleanup.service is not present. See http://www.altlinux.org/Services_Policy for details.
shrek hunspell-1.3.1-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/libparsers.a
/usr/share/man/hu/man1/hunspell.1
/usr/share/man/hu/man4/hunspell.4
shrek hunspell-ru-20110128-alt1.noarch rpm-package-is-obsoleted warn The package is obsoleted by the package hunspell-ru-lebedev-0.99g5-alt12.1.noarch, but is still alive and in the repository. Consider removing the package, or, if you want the package to be alive, ask the maintainer of hunspell-ru-lebedev-0.99g5-alt12.1.noarch to remove Obsoletes: tag.
shrek hunspell-tt-20080617-alt2.noarch missing-url info Missing Url: in a package.
shrek hunspell-utils-1.3.1-alt1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/analyze conflicts with the package SNNS-4.3-alt1.1.1.1.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek hunspell-utils-1.3.1-alt1.x86_64 unsafe-tmp-usage-in-scripts fail The test discovered scripts with errors which may be used by a user for damaging important system files. For example if a script uses in its work a temp file which is created in /tmp directory, then every user can create symlinks with the same name (pattern) in this directory in order to destroy or rewrite some system or another user's files. Scripts _must_ _use_ mktemp/tempfile or must use $TMPDIR. mktemp/tempfile is safest. $TMPDIR is safer than /tmp/ because libpam-tmpdir creates a subdirectory of /tmp that is only accessible by that user, and then sets TMPDIR and other variables to that. Hence, it doesn't matter nearly as much if you create a non-random filename, because nobody but you can access it. Found error in /usr/bin/wordforms: $ grep -A5 -B5 /tmp/ /usr/bin/wordforms fx=0 case $1 in -s) fx=1; shift;; -p) fx=2; shift;; esac test -h /tmp/wordforms.aff && rm /tmp/wordforms.aff ln -s $PWD/$1 /tmp/wordforms.aff # prepared dic only with the query word echo 1 >/tmp/wordforms.dic grep "^$3/" $2 >>/tmp/wordforms.dic echo $3 | awk -v "fx=$fx" ' fx!=2 && FILENAME!="-" && /^SFX/ && NF > 4{split($4,a,"/");clen=($3=="0") ? 0 : length($3);sfx[a[1],clen]=a[1];sfxc[a[1],clen]=clen;next} fx!=1 && FILENAME!="-" && /^PFX/ && NF > 4{split($4,a,"/");clen=($3=="0") ? 0 : length($3);pfx[a[1],clen]=a[1];pfxc[a[1],clen]=clen;next} FILENAME=="-"{ wlen=length($1) -- for (j in pfx) {if (wlen<=pfxc[j]) continue; for(i in sfx){clen=sfxc[i];if (wlen<=clen || wlen <= (clen + pfxc[j]))continue; print (pfx[j]=="0" ? "" : pfx[j]) substr($1, pfxc[j]+1, wlen-clen-pfxc[j]) (sfx[i]=="0" ? "": sfx[i]) }} } } ' /tmp/wordforms.aff - | hunspell -d /tmp/wordforms -G -l
shrek hyphen-tt-20080619-alt2.noarch missing-url info Missing Url: in a package.
shrek icc-profiles-1.0.1-alt1.noarch missing-url info Missing Url: in a package.
shrek iscsi-scst-3.1.0-alt1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek kernel-source-3.4-1.0.0-alt1.noarch missing-url info Missing Url: in a package.
shrek libX11-devel-1.6.4-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek libXdmcp-1.1.1-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/libXdmcp/xdmcp.html.db
/usr/share/doc/libXdmcp/xdmcp.pdf.db
/usr/share/doc/libXdmcp/xdmcp.xml
shrek libXt-1.1.4-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/libXt/CH01.xml
/usr/share/doc/libXt/CH02.xml
/usr/share/doc/libXt/CH03.xml
/usr/share/doc/libXt/CH04.xml
/usr/share/doc/libXt/CH05.xml
/usr/share/doc/libXt/CH06.xml
/usr/share/doc/libXt/CH07.xml
/usr/share/doc/libXt/CH08.xml
/usr/share/doc/libXt/CH09.xml
/usr/share/doc/libXt/CH10.xml
/usr/share/doc/libXt/CH11.xml
/usr/share/doc/libXt/CH12.xml
/usr/share/doc/libXt/CH13.xml
/usr/share/doc/libXt/acknowledgement.xml
/usr/share/doc/libXt/appA.xml
/usr/share/doc/libXt/appB.xml
/usr/share/doc/libXt/appC.xml
/usr/share/doc/libXt/appD.xml
/usr/share/doc/libXt/appE.xml
/usr/share/doc/libXt/appF.xml
/usr/share/doc/libXt/intrinsics.html.db
/usr/share/doc/libXt/intrinsics.pdf.db
/usr/share/doc/libXt/intrinsics.xml
/usr/share/doc/libXt/preface.xml
shrek libXtst-1.2.2-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/libXtst/recordlib.html.db
/usr/share/doc/libXtst/recordlib.pdf.db
/usr/share/doc/libXtst/recordlib.xml
/usr/share/doc/libXtst/xtestlib.html.db
/usr/share/doc/libXtst/xtestlib.pdf.db
/usr/share/doc/libXtst/xtestlib.xml
shrek libXvMC-1.0.8-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/libXvMC/XvMC_API.txt
shrek libcdio++-2.0.0-alt1.1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/lib64/libiso9660++.so.0.0.0 conflicts with the package libcdio12++-0.82-alt3.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek libcelt-0.10.0-alt1.qa1.src beehive-log-dependency-needs-epoch-x86_64 info libcelt-devel: dependency on libcelt needs Epoch
libcelt-utils: dependency on libcelt needs Epoch
shrek libdbus-devel-1.10.24-alt2.S1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek libgimp-devel-2.8.22-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek libgle-doc-3.1.0-alt7.3.x86_64 arch-dep-package-consists-of-usr-share info The package consists of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek libjack-devel-1.9.10-alt2.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek libopenobex-1.7.2-alt1.x86_64 docdir-is-not-owned warn package places files into /usr/share/doc/%name-%version directory but does not own it.
shrek libwps-tools-0.4.7-alt2.x86_64 rpm-filesystem-conflict-file-file warn There are file conflicts with the package libwps3-tools-0.3.0-alt2.x86_64, for example, /usr/bin/wks2csv (6 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek libxcb-devel-1.12-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek mythes-ru-20061016-alt1.noarch missing-url info Missing Url: in a package.
shrek nc6-1.0-alt1.x86_64 missing-url info Missing Url: in a package.
shrek nc6-debuginfo-1.0-alt1.x86_64 missing-url info Missing Url: in a package.
shrek pitivi-0.99-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek pulseaudio-equalizer-2.7-alt1.noarch unsafe-tmp-usage-in-scripts fail The test discovered scripts with errors which may be used by a user for damaging important system files. For example if a script uses in its work a temp file which is created in /tmp directory, then every user can create symlinks with the same name (pattern) in this directory in order to destroy or rewrite some system or another user's files. Scripts _must_ _use_ mktemp/tempfile or must use $TMPDIR. mktemp/tempfile is safest. $TMPDIR is safer than /tmp/ because libpam-tmpdir creates a subdirectory of /tmp that is only accessible by that user, and then sets TMPDIR and other variables to that. Hence, it doesn't matter nearly as much if you create a non-random filename, because nobody but you can access it. Found error in /usr/bin/pulseaudio-equalizer: $ grep -A5 -B5 /tmp/ /usr/bin/pulseaudio-equalizer if [ "$1" = "disable" -o "$1" = "enable" ]; then echo "-------------------------------------" echo "Current operation: disabling equalizer" echo "-------------------------------------" echo -n >/tmp/eqcommands.sh # Unload & reload stream-restore module echo "Unloading & reloading stream-restore module..." echo >>/tmp/eqcommands.sh "unload-module $(pacmd list | grep -B1 -m1 'name: ' | grep ' index: ' | sed 's/ index: //g')" echo >>/tmp/eqcommands.sh "load-module module-stream-restore" # Unload LADSPA sink module (if it is already loaded) echo "Unloading module-ladspa-sink..." echo >>/tmp/eqcommands.sh "unload-module $(pacmd list | grep -B1 -m1 'name: ' | grep ' index: ' | sed 's/ index: //g')" # Move active client sinks to ALSA sink echo "Moving active PulseAudio clients to ALSA sink ($PA_MASTER_SINK)..." echo >>/tmp/eqcommands.sh "$(pacmd "list-sink-inputs" | grep 'index: ' | sed 's/ index: /move-sink-input /g' | sed "s/$/ $PA_MASTER_SINK/g")" # Transfer current mute/sink volume to ALSA sink echo "Transferring current mute ($PA_CURRENT_MUTE) & volume ($PA_CURRENT_VOLUME%) to ALSA sink ($PA_MASTER_SINK)..." echo >>/tmp/eqcommands.sh "set-default-sink $PA_MASTER_SINK" echo >>/tmp/eqcommands.sh "set-sink-volume $PA_MASTER_SINK $PA_REAL_VOLUME" echo >>/tmp/eqcommands.sh "set-sink-mute $PA_MASTER_SINK $PA_CURRENT_MUTE" # Execute all queued commands (for potential speed benefit)... pacmd /dev/null fi if [ "$1" = "enable" ]; then echo "-------------------------------------" echo "Current operation: enabling equalizer" echo "-------------------------------------" echo -n >/tmp/eqcommands.sh # Unload & reload stream-restore module with restore_device option disabled (to ensure that previously cached per-client sinks are not used) echo "Unloading & reloading stream-restore module..." echo >>/tmp/eqcommands.sh "unload-module $(pacmd list | grep -B1 -m1 'name: ' | grep ' index: ' | sed 's/ index: //g')" echo >>/tmp/eqcommands.sh "load-module module-stream-restore restore_device=false" # Load LADSPA sink module echo "Loading module-ladspa-sink..." echo >>/tmp/eqcommands.sh "load-module module-ladspa-sink sink_name=$PA_LADSPA_SINK master=$PA_MASTER_SINK plugin=$PA_LADSPA_PLUGIN label=$PA_LADSPA_LABEL control=$PA_LADSPA_CONTROLS" # Transfer current sink mute/volume to LADSPA sink echo "Transferring current mute ($PA_CURRENT_MUTE) & volume ($PA_CURRENT_VOLUME%) to LADSPA sink ($PA_LADSPA_SINK)..." echo >>/tmp/eqcommands.sh "set-sink-volume $PA_LADSPA_SINK $PA_REAL_VOLUME" echo >>/tmp/eqcommands.sh "set-sink-mute $PA_LADSPA_SINK $PA_CURRENT_MUTE" # Unmute & set preamp level on ALSA sink (as LADSPA sink will act as primary volume control) echo "Setting ALSA sink ($PA_MASTER_SINK) preamp ("$PA_PREAMP"x)..." #echo >>/tmp/eqcommands.sh "set-sink-volume $PA_MASTER_SINK $PA_REAL_PREAMP" echo >>/tmp/eqcommands.sh "set-sink-mute $PA_MASTER_SINK 0" # Set the LADSPA sink as the default echo "Setting LADSPA sink ($PA_LADSPA_SINK) as default sink..." echo >>/tmp/eqcommands.sh "set-default-sink $PA_LADSPA_SINK" # Move currently active client sinks to LADSPA sink echo "Moving active PulseAudio clients to LADSPA sink ($PA_LADSPA_SINK)..." echo >>/tmp/eqcommands.sh "$(pacmd "list-sink-inputs" | grep 'index: ' | sed 's/ index: /move-sink-input /g' | sed "s/$/ $PA_LADSPA_SINK/g")" # Execute all queued commands (for potential speed benefit)... pacmd /dev/null fi if [ "$1" = "" -o "$1" = "-h" -o "$1" = "--help" ]; then echo -e "Usage: $SCRIPT_NAME [option]" echo -e "WARNING: This is for internal use by the pulseaudio-equalizer-gtk interface."
shrek pve-cluster-5.0.19-alt3.S1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-container-2.0.17-alt3.S1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-firewall-3.0.5-alt3.S1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-ha-manager-2.0.4-alt3.S1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-lxc-2.1.0-alt1.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
shrek pve-lxc-2.1.0-alt1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-lxc-2.1.0-alt1.x86_64 unsafe-tmp-usage-in-scripts fail The test discovered scripts with errors which may be used by a user for damaging important system files. For example if a script uses in its work a temp file which is created in /tmp directory, then every user can create symlinks with the same name (pattern) in this directory in order to destroy or rewrite some system or another user's files. Scripts _must_ _use_ mktemp/tempfile or must use $TMPDIR. mktemp/tempfile is safest. $TMPDIR is safer than /tmp/ because libpam-tmpdir creates a subdirectory of /tmp that is only accessible by that user, and then sets TMPDIR and other variables to that. Hence, it doesn't matter nearly as much if you create a non-random filename, because nobody but you can access it. Found error in /usr/share/lxc/templates/lxc-plamo: $ grep -A5 -B5 /tmp/ /usr/share/lxc/templates/lxc-plamo /^# Initialize sysctl/;/^echo "Starting services/-1d /^sync/;/^# All done/-1d w EOF # /etc/rc.d/rc.inet1.tradnet head -n-93 $rootfs/sbin/netconfig.tradnet > /tmp/netconfig.rconly cat <<- EOF >> /tmp/netconfig.rconly PCMCIA=n RC=$rootfs/etc/rc.d/rc.inet1.tradnet IFCONFIG=sbin/ifconfig ROUTE=sbin/route INET1SCHEME=var/run/inet1-scheme -- DHCPCD=usr/sbin/dhclient LOOPBACK=y make_config_file EOF rm -f $rootfs/etc/rc.d/rc.inet1.tradnet sh /tmp/netconfig.rconly rm -f /tmp/netconfig.rconly sed -i '/cmdline/s/if/& false \&\&/' $rootfs/etc/rc.d/rc.inet1.tradnet # /etc/rc.d/rc.inet2 sed -i '/rpc.mountd/s/^/#/' $rootfs/etc/rc.d/rc.inet2 sed -i '/modprobe/s/^/#/' $rootfs/etc/rc.d/rc.inet2 # configure to start only the minimum of service
shrek pve-manager-5.1.39-alt3.S1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
shrek pve-manager-5.1.39-alt3.S1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/vzdump conflicts with the package vzdump-1.0-alt2.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek pve-manager-5.1.39-alt3.S1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek pve-qemu-common-2.9.1-alt6.S1.x86_64 rpm-filesystem-conflict-file-file warn File /usr/share/man/man1/qemu-img.1.xz conflicts with the package qemu-img-2.11.0-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/qemu/slof.bin conflicts with the package qemu-system-ppc-core-2.11.0-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek pve-qemu-common-2.9.1-alt6.S1.x86_64 udev-files-in-etc warn Systemd files Policy Draft violation: etc/udev/rules.d/ is reserved for sysadmin. Please, move /etc/udev/rules.d/90-qemu-kvm.rules to \%_udevrulesdir/.
shrek pve-qemu-img-2.9.1-alt6.S1.x86_64 rpm-filesystem-conflict-file-file warn Files /usr/bin/virtfs-proxy-helper /usr/libexec/qemu-bridge-helper conflict with the package qemu-tools-2.11.0-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek pve-qemu-system-2.9.1-alt6.S1.x86_64 rpm-filesystem-conflict-file-file warn Files /usr/bin/qemu-kvm /usr/bin/qemu-system-x86_64 conflict with the package qemu-system-x86-core-2.11.0-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek python-module-gst-0.10.22-alt2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/gstreamer-0.10/libgstpython.so
shrek rtkit-0.11-alt1.S1.x86_64 dbus-xml-not-in-devel info file /usr/share/dbus-1/interfaces/org.freedesktop.RealtimeKit1.xml is not used in run time. Move it to the -devel subpackage.
shrek scst-utils-3.1.0-alt1.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
shrek sdlaplay-0.0.4-alt1.qa1.x86_64 missing-url info Missing Url: in a package.
shrek sdlaplay-debuginfo-0.0.4-alt1.qa1.x86_64 missing-url info Missing Url: in a package.
shrek tigervnc-common-1.8.0-alt2.x86_64 rpm-filesystem-conflict-file-file warn File /usr/bin/vncpasswd conflicts with the package turbovnc-server-1.2.1-alt3.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
shrek tuned-2.7.1-alt2.noarch init-lsb warn /etc/rc.d/init.d/tuned: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
shrek tuned-gtk-2.7.1-alt2.noarch freedesktop-categories warn Menu-related Additional Categories (http://standards.freedesktop.org/menu-spec/latest/apa.html) not found in /usr/share/applications/tuned-gui.desktop. Please add it or report a bug against this test if you already have registered one (not including menu unrelated ones as Core or Qt).
shrek x-cursor-theme-Bluecurve-0.120-alt1.noarch missing-url info Missing Url: in a package.
shrek xorg-96dpi-0.1-alt1.noarch missing-url info Missing Url: in a package.
shrek xorg-drv-wacom-0.33.0-alt1.x86_64 udev-files-in-etc warn Systemd files Policy Draft violation: etc/udev/rules.d/ is reserved for sysadmin. Please, move /etc/udev/rules.d/10-wacom.rules to \%_udevrulesdir/.
shrek xorg-sdk-1.19.6-alt1.x86_64 altlinux-policy-rpm-macros-packaging warn package contains rpm macro files in /etc/rpm/macros.d/. package name should be rpm-build-* or rpm-macros-* according to http://www.altlinux.org/Drafts/RPMMacrosPackaging
shrek xorg-server-control-1.3-alt1.noarch missing-url info Missing Url: in a package.
shrek xorg-xcbproto-devel-1.12-alt1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/pkgconfig/xcb-proto.pc conflicts with the package libxcbutil-proto-1.12-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
zerg fontconfig-2.12.6-alt1.S1.x86_64 library-pkgnames info package contains public library which is used in external packages: name should be lib* according to http://altlinux.org/Drafts/SharedLibs
zerg fontconfig-2.12.6-alt1.S1.x86_64 symlink-extra-slash info /etc/fonts/conf.d/10-autohint.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-hinting-full.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-hinting-medium.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-hinting-none.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-hinting-slight.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-no-sub-pixel.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-scale-bitmap-fonts.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-sub-pixel-bgr.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-sub-pixel-rgb.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-sub-pixel-vbgr.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-sub-pixel-vrgb.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/10-unhinted.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/11-lcdfilter-default.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/11-lcdfilter-legacy.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
/etc/fonts/conf.d/11-lcdfilter-light.conf:This symlink contains two successive slashes (//) or ends with a slash (/). symlinks should be as short as possible.
zerg libcdparanoia-devel-10.2-alt6.x86_64 rpm-filesystem-conflict-file-file warn File /usr/include/utils.h conflicts with the package libbcg729-devel-0.1-alt2.x86_64. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.

generated by repocop at Tue Feb 13 06:37:54 2018