Repocop reports by acl

  packager rpm id test status message
alexey cve-basealt-20200318-alt1.noarch missing-url info Missing Url: in a package.
nbr checker-0.7-alt2.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
nbr dwall-0.5.3-alt3.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
nbr dwall-0.5.3-alt3.x86_64 init-condrestart warn /etc/rc.d/init.d/dwall: missing condstop target. Note: alt-specific script %_sbindir/preun_service (used in %preun_service macro) depends on condstop. It is wise to add condstop anyway.
nbr dwall-0.5.3-alt3.x86_64 init-lsb fail /etc/rc.d/init.d/dwall: not systemd compatible: lsb init header missing and dwall.service is not present. See http://www.altlinux.org/Services_Policy for details.
nbr erlang-21.3.6-alt3.src beehive-log-non-strict-dependency-i586 info erlang: non-strict dependency on erlang-otp
erlang-odbc-devel: non-strict dependency on erlang-odbc
erlang-common_test-devel: non-strict dependency on erlang-common_test
erlang-otp-devel: non-strict dependency on erlang-otp
nbr erlang-21.3.6-alt3.src beehive-log-non-strict-dependency-x86_64 info erlang: non-strict dependency on erlang-otp
erlang-odbc-devel: non-strict dependency on erlang-odbc
erlang-common_test-devel: non-strict dependency on erlang-common_test
erlang-otp-devel: non-strict dependency on erlang-otp
nbr erlang-21.3.6-alt3.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
nbr hercstudio-1.5.0-alt2.x86_64 iconsdir experimental Please, move pixmaps from /usr/share/pixmaps to %_liconsdir, %_niconsdir, %_miconsdir according to their size. See http://www.altlinux.org/IconPathsPolicy.
nbr hercules-3.13-alt1.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/sbin/hercules-run
nbr installer-feature-vm-fs-stage2-0.3-alt2.noarch rpm-filesystem-conflict-file-file warn File /usr/share/install2/initinstall.d/05-vm-profile-ofs conflicts with the package installer-feature-vm-ofs-stage2-0.3-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
nbr installer-feature-vm-fs-stage3-0.3-alt2.noarch rpm-filesystem-conflict-file-file warn File /usr/share/install2/preinstall.d/01-move-fs-ofs conflicts with the package installer-feature-vm-ofs-stage3-0.3-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
nbr integ-0.2-alt4.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
nbr integrity-notifier-0.6.1-alt4.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/bin/integrity-notifier /usr/bin/inotifier-functions.sh
nbr integrity-notifier-0.6.1-alt4.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
nbr libpst-0.6.68-alt2.2.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/python2.7/site-packages/_libpst.la
nbr libpst-0.6.68-alt2.2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib64/python2.7/site-packages/_libpst.la
nbr nagios-3.0.6-alt13.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/nagios/eventhandlers/disable_active_service_checks.p3
/usr/lib/nagios/eventhandlers/disable_notifications.p3
/usr/lib/nagios/eventhandlers/enable_active_service_checks.p3
/usr/lib/nagios/eventhandlers/enable_notifications.p3
/usr/lib/nagios/eventhandlers/handle-master-host-event.p3
/usr/lib/nagios/eventhandlers/handle-master-proc-event.p3
/usr/lib/nagios/eventhandlers/obsessive_svc_handler.p3
/usr/lib/nagios/eventhandlers/submit_check_result.p3
/usr/lib/nagios/eventhandlers/submit_check_result_via_nsca.p3
nbr nagios-3.0.6-alt13.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/lib/nagios/eventhandlers/disable_active_service_checks.p3
/usr/lib/nagios/eventhandlers/disable_notifications.p3
/usr/lib/nagios/eventhandlers/enable_active_service_checks.p3
/usr/lib/nagios/eventhandlers/enable_notifications.p3
/usr/lib/nagios/eventhandlers/handle-master-host-event.p3
/usr/lib/nagios/eventhandlers/handle-master-proc-event.p3
/usr/lib/nagios/eventhandlers/obsessive_svc_handler.p3
/usr/lib/nagios/eventhandlers/submit_check_result.p3
/usr/lib/nagios/eventhandlers/submit_check_result_via_nsca.p3
nbr nagios-3.0.6-alt13.x86_64 checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/nagios
nbr nagios-3.0.6-alt13.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
nbr nagios-3.0.6-alt13.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
nbr nagios-common-3.0.6-alt13.x86_64 systemd-files-in-etc warn Systemd files Policy Draft violation: etc/tmpfiles.d/ is reserved for sysadmin overrides. Please, move /etc/tmpfiles.d/nagios.conf to \%_tmpfilesdir/.
nbr nagios-nrpe-3.2.1-alt5.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
nbr nagios-www-apache2-3.0.6-alt13.x86_64 altlinux-policy-obsolete-httpd2-reload info This package contains httpd2 restart/reload calls in its post/un scripts. But those calls are deprecated by httpd2.filetrigger that activates by files in /etc/httpd2/ or %_libdir/apache2/modules/. It should be safe to remove those calls and rely on the filetrigger instead.
nbr nagstamon-3.4.1-alt3.noarch iconsdir experimental Please, move pixmaps from /usr/share/pixmaps to %_liconsdir, %_niconsdir, %_miconsdir according to their size. See http://www.altlinux.org/IconPathsPolicy.
nbr python-module-pylama-6.1.1-alt3.git20141029.3.noarch sisyphus_check fail sisyphus_check failed: /ALT/Sisyphus/files/noarch/RPMS/python-module-pylama-6.1.1-alt3.git20141029.3.noarch.rpm: forbidden requires: /usr/bin/python sisyphus_check: check-deps ERROR: package dependencies violation /ALT/Sisyphus/files/noarch/RPMS/python-module-pylama-6.1.1-alt3.git20141029.3.noarch.rpm: The use of such a license name is ambiguous: LGPL
nbr python-module-pylama-6.1.1-alt3.git20141029.3.src altlinux-python-python2-in-spec warn spec file explicitly calls /usr/bin/python. It is deprecated binary.
nbr python-module-responses-0.10.9-alt1.src altlinux-python-python2-in-spec warn spec file explicitly calls /usr/bin/python. It is deprecated binary.
nbr python-module-yarn-0.4pseudo_really0.2-alt5.1.1.noarch altlinux-python-test-is-packaged info /usr/lib/python2.7/site-packages/yarn/tests/test_auth.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_auth.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_auth.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_html.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_html.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_html.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_http.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_http.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_http.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_maildir.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_maildir.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_maildir.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_message.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_message.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_message.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_metaweblog.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_metaweblog.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_metaweblog.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_opml.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_opml.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_opml.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_rsd.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_rsd.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_rsd.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_url.py: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_url.pyc: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
/usr/lib/python2.7/site-packages/yarn/tests/test_url.pyo: It is the file in the package whose name matches the format python modules use for test files. It may have been installed by accident. Remove it or move it to the -devel subpackage, if the test is required to build other packages. See http://www.altlinux.org/Python_Policy for details.
nbr python3-module-pcs-0.10.6-alt1.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/pcsd
nbr python3-module-pcs-0.10.6-alt1.noarch init-condrestart warn /etc/rc.d/init.d/pcsd: missing condstop target. Note: alt-specific script %_sbindir/preun_service (used in %preun_service macro) depends on condstop. It is wise to add condstop anyway.
nbr python3-module-snmp-0.10.6-alt1.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
nbr qstopmotion-2.3.2-alt4.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
nbr rabbitmq-server-3.8.3-alt2.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /etc/rc.d/init.d/rabbitmq
nbr rabbitmq-server-3.8.3-alt2.noarch subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
nbr rabbitmq-server-3.8.3-alt2.noarch unsafe-tmp-usage-in-scripts fail The test discovered scripts with errors which may be used by a user for damaging important system files. For example if a script uses in its work a temp file which is created in /tmp directory, then every user can create symlinks with the same name (pattern) in this directory in order to destroy or rewrite some system or another user's files. Scripts _must_ _use_ mktemp/tempfile or must use $TMPDIR. mktemp/tempfile is safest. $TMPDIR is safer than /tmp/ because libpam-tmpdir creates a subdirectory of /tmp that is only accessible by that user, and then sets TMPDIR and other variables to that. Hence, it doesn't matter nearly as much if you create a non-random filename, because nobody but you can access it. Found error in /usr/lib/ocf/resource.d/rabbitmq/rabbitmq-server-ha: $ grep -A5 -B5 /tmp/ /usr/lib/ocf/resource.d/rabbitmq/rabbitmq-server-ha The debug flag for agent (${OCF_RESKEY_binary}) instance. In the /tmp/ directory will be created rmq-* files for log some operations and ENV values inside OCF-script. AMQP server (${OCF_RESKEY_binary}) debug flag -- local rc=$OCF_ERR_GENERIC local LH="${LL} monitor:" ocf_log debug "${LH} action start." if [ "${OCF_RESKEY_debug}" = 'true' ] ; then d=`date '+%Y%m%d %H:%M:%S'` echo $d >> /tmp/rmq-monitor.log env >> /tmp/rmq-monitor.log echo "$d [monitor] start='${OCF_RESKEY_CRM_meta_notify_start_uname}' stop='${OCF_RESKEY_CRM_meta_notify_stop_uname}' active='${OCF_RESKEY_CRM_meta_notify_active_uname}' inactive='${OCF_RESKEY_CRM_meta_notify_inactive_uname}'" >> /tmp/rmq-ocf.log fi get_monitor rc=$? ocf_log debug "${LH} role: ${OCF_RESKEY_CRM_meta_role}" ocf_log debug "${LH} result: $rc" -- local LH="${LL} start:" local nowtime if [ "${OCF_RESKEY_debug}" = 'true' ] ; then d=`date '+%Y%m%d %H:%M:%S'` echo $d >> /tmp/rmq-start.log env >> /tmp/rmq-start.log echo "$d [start] start='${OCF_RESKEY_CRM_meta_notify_start_uname}' stop='${OCF_RESKEY_CRM_meta_notify_stop_uname}' active='${OCF_RESKEY_CRM_meta_notify_active_uname}' inactive='${OCF_RESKEY_CRM_meta_notify_inactive_uname}'" >> /tmp/rmq-ocf.log fi ocf_log info "${LH} action begin." get_status -- local rc=$OCF_ERR_GENERIC local LH="${LL} stop:" if [ "${OCF_RESKEY_debug}" = 'true' ] ; then d=$(date '+%Y%m%d %H:%M:%S') echo $d >> /tmp/rmq-stop.log env >> /tmp/rmq-stop.log echo "$d [stop] start='${OCF_RESKEY_CRM_meta_notify_start_uname}' stop='${OCF_RESKEY_CRM_meta_notify_stop_uname}' active='${OCF_RESKEY_CRM_meta_notify_active_uname}' inactive='${OCF_RESKEY_CRM_meta_notify_inactive_uname}'" >> /tmp/rmq-ocf.log fi ocf_log info "${LH} action begin." ocf_log info "${LH} Deleting master attribute" -- local LH="${LL} notify:" local nodelist if [ "${OCF_RESKEY_debug}" = 'true' ] ; then d=`date '+%Y%m%d %H:%M:%S'` echo $d >> /tmp/rmq-notify.log env >> /tmp/rmq-notify.log echo "$d [notify] ${OCF_RESKEY_CRM_meta_notify_type}-${OCF_RESKEY_CRM_meta_notify_operation} promote='${OCF_RESKEY_CRM_meta_notify_promote_uname}' demote='${OCF_RESKEY_CRM_meta_notify_demote_uname}' master='${OCF_RESKEY_CRM_meta_notify_master_uname}' slave='${OCF_RESKEY_CRM_meta_notify_slave_uname}' start='${OCF_RESKEY_CRM_meta_notify_start_uname}' stop='${OCF_RESKEY_CRM_meta_notify_stop_uname}' active='${OCF_RESKEY_CRM_meta_notify_active_uname}' inactive='${OCF_RESKEY_CRM_meta_notify_inactive_uname}'" >> /tmp/rmq-ocf.log fi if [ "${OCF_RESKEY_CRM_meta_notify_type}" = 'post' ] ; then # POST- anything notify section case "$OCF_RESKEY_CRM_meta_notify_operation" in -- local rc=$OCF_ERR_GENERIC local LH="${LL} promote:" if [ "${OCF_RESKEY_debug}" = 'true' ] ; then d=$(date '+%Y%m%d %H:%M:%S') echo $d >> /tmp/rmq-promote.log env >> /tmp/rmq-promote.log echo "$d [promote] start='${OCF_RESKEY_CRM_meta_notify_start_uname}' stop='${OCF_RESKEY_CRM_meta_notify_stop_uname}' active='${OCF_RESKEY_CRM_meta_notify_active_uname}' inactive='${OCF_RESKEY_CRM_meta_notify_inactive_uname}'" >> /tmp/rmq-ocf.log fi ocf_log info "${LH} action begin." get_monitor
nbr rpm-cve-browser-0.1-alt1.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/LICENSE
/usr/share/doc/README.md
nbr rpm-cve-browser-0.1-alt1.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/LICENSE
/usr/share/doc/README.md
nbr ruby-backports-doc-3.7.0-alt1.1.noarch rpm-filesystem-conflict-file-file warn File /usr/share/ri/site/Array/cdesc-Array.ri conflicts with the package ruby-algebrick-doc-0.7.5-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Hash/cdesc-Hash.ri conflicts with the package ruby-amazon-ec2-doc-0.9.17-alt3.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Integer/cdesc-Integer.ri /usr/share/ri/site/Integer/ord-i.ri conflict with the package ruby-archive-zip-doc-0.11.0-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
There are file conflicts with the package ruby-awesome-print-doc-1.8.0-alt1.1.noarch, for example, /usr/share/ri/site/Kernel/cdesc-Kernel.ri (6 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-azure-core-doc-0.1.14-alt2.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-azure-storage-doc-0.15.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Array/cdesc-Array.ri /usr/share/ri/site/String/cdesc-String.ri conflict with the package ruby-chef-sugar-doc-3.4.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Kernel/cdesc-Kernel.ri conflicts with the package ruby-em-synchrony-doc-1.0.6-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
There are file conflicts with the package ruby-extlib-doc-0.9.16-alt1.1.noarch, for example, /usr/share/ri/site/Array/cdesc-Array.ri (9 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
There are file conflicts with the package ruby-fission-doc-0.5.0-alt1.1.noarch, for example, /usr/share/ri/site/Array/cdesc-Array.ri (4 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Hash/cdesc-Hash.ri /usr/share/ri/site/String/cdesc-String.ri conflict with the package ruby-fog-softlayer-doc-1.1.4-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Hash/cdesc-Hash.ri /usr/share/ri/site/Hash/symbolize_keys%21-i.ri conflict with the package ruby-fog-xenserver-doc-0.3.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/IO/cdesc-IO.ri conflicts with the package ruby-io-like-doc-0.3.0-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Kernel/cdesc-Kernel.ri /usr/share/ri/site/Module/cdesc-Module.ri conflict with the package ruby-java-doc-0.0.2-alt4.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-kindlerb-doc-1.2.0-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Kernel/cdesc-Kernel.ri /usr/share/ri/site/Kernel/singleton_class-i.ri conflict with the package ruby-memoist-doc-0.16.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Process/cdesc-Process.ri conflicts with the package ruby-mixlib-shellout-doc-2.4.0-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Symbol/cdesc-Symbol.ri conflicts with the package ruby-mongo-doc-2.6.2-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Kernel/cdesc-Kernel.ri conflicts with the package ruby-polyglot-doc-0.3.5-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Process/cdesc-Process.ri conflicts with the package ruby-process-group-doc-1.1.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Process/cdesc-Process.ri conflicts with the package ruby-process-pipeline-doc-1.0.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Kernel/cdesc-Kernel.ri conflicts with the package ruby-retriable-doc-3.1.2-alt3.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
There are file conflicts with the package ruby-rr-doc-1.2.1-alt1.1.noarch, for example, /usr/share/ri/site/Array/cdesc-Array.ri (5 file conflicts in total). Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-scrub_rb-doc-1.0.1-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/Regexp/cdesc-Regexp.ri conflicts with the package ruby-serverspec-doc-2.41.3-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Array/cdesc-Array.ri /usr/share/ri/site/Kernel/cdesc-Kernel.ri /usr/share/ri/site/Process/cdesc-Process.ri conflict with the package ruby-sfl-doc-2.1-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-specinfra-doc-2.77.0-alt1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
Files /usr/share/ri/site/Numeric/cdesc-Numeric.ri /usr/share/ri/site/String/cdesc-String.ri conflict with the package ruby-temple-doc-0.8.0-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
File /usr/share/ri/site/String/cdesc-String.ri conflicts with the package ruby-zhexdump-doc-0.0.2-alt1.1.noarch. Moreover, the packages have no explicit conflicts with each other. You should add explicit conflicts, or, if conflicts are avoidable, consider using alternatives.
nbr ruby-mustermann-1.1.1-alt1.src beehive-log-non-strict-dependency-i586 info ruby-mustermann: non-strict dependency on gem-mustermann
ruby-mustermann: non-strict dependency on gem-mustermann-contrib
nbr ruby-mustermann-1.1.1-alt1.src beehive-log-non-strict-dependency-x86_64 info ruby-mustermann: non-strict dependency on gem-mustermann
ruby-mustermann: non-strict dependency on gem-mustermann-contrib
nbr smack-utils-1.3.1-alt1.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libsmack.so but just /usr/lib64/libsmack.so.1.3.1. According to SharedLibs Policy Draft, symlink /usr/lib64/libsmack.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libsmack.so to \%files of smack-utils-1.3.1-alt1.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
nbr splitvt-1.6.6_6-alt1.qa1.x86_64 uncompressed-manpages info Package contains uncompressed manual pages.
nbr teachercp-0.1-alt2.qa1.noarch freedesktop-categories warn Menu-related Additional Categories (http://standards.freedesktop.org/menu-spec/latest/apa.html) not found in /usr/share/applications/Teacher.desktop. Please add it or report a bug against this test if you already have registered one (not including menu unrelated ones as Core or Qt).
Menu-related Additional Categories (http://standards.freedesktop.org/menu-spec/latest/apa.html) not found in /usr/share/applications/Student.desktop. Please add it or report a bug against this test if you already have registered one (not including menu unrelated ones as Core or Qt).
nbr teachercp-0.1-alt2.qa1.noarch freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/Teacher.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
rider libselinux-3.0-alt1.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
rider selinux-policy-alt-0.0.50-alt4.noarch checkbashisms experimental checkbashisms utility found possible bashisms in: /usr/bin/slrun2
rider selinux-policy-alt-0.0.50-alt4.noarch missing-url info Missing Url: in a package.
rider selinux-policy-alt-0.0.50-alt4.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
rider selinux-policy-alt-0.0.50-alt4.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/selinux-policy-alt/README
rider selinux-policy-alt-0.0.50-alt4.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/usr/share/doc/selinux-policy-alt/README
sem alterator-fbi-5.49-alt1.x86_64 init-lsb warn /etc/rc.d/init.d/ahttpd: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
sem alterator-fbi-5.49-alt1.x86_64 subdir-in-var-run info Found a subdir in /var/run or /var/lock. /var/run and /var/lock may be mounted as temporary filesystems, so the init.d scripts must handle this correctly. This will typically amount to creating any required subdirectories dynamically when the init.d script is run, rather than including them in the package and relying on rpm to create them.
sin virtualbox-6.1.10-alt1.src altlinux-policy-obsolete-buildreq warn Build dependency on rpm-build-ubt is obsolete and should be dropped to get rid of rpm-build-ubt package.
sin virtualbox-6.1.10-alt1.src altlinux-python-obsolete-buildreq-python-dev warn python-dev is obsolete according to Python Policy (http://www.altlinux.org/Python_Policy). Please, use BuildRequires: python-devel.
sin virtualbox-6.1.10-alt1.src altlinux-python-python2-in-spec warn spec file explicitly calls /usr/bin/python. It is deprecated binary.
sin virtualbox-6.1.10-alt1.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
sin virtualbox-common-6.1.10-alt1.x86_64 init-lsb warn /etc/rc.d/init.d/virtualbox: lsb init header missing. See http://www.altlinux.org/Services_Policy for details.
sin virtualbox-doc-6.1.10-alt1.x86_64 arch-dep-package-consists-of-usr-share info The package consists of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
sin virtualbox-doc-6.1.10-alt1.x86_64 desktop-mime-entry warn update-desktop-database call in post/postun is deprecated
sin virtualbox-guest-additions-6.1.10-alt1.x86_64 systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.
sin virtualbox-guest-utils-6.1.10-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
sin virtualbox-guest-utils-6.1.10-alt1.x86_64 init-condrestart warn /etc/rc.d/init.d/vboxadd-service: missing condrestart target. Note: alt-specific script %_sbindir/post_service (used in %post_service macro) depends on condrestart. It is wise to add condrestart anyway./etc/rc.d/init.d/vboxadd-service: missing condstop target. Note: alt-specific script %_sbindir/preun_service (used in %preun_service macro) depends on condstop. It is wise to add condstop anyway.
sin virtualbox-webservice-6.1.10-alt1.x86_64 init-but-no-native-systemd info The package have SysV init script(s) but no native systemd files.
sin virtualbox-webservice-6.1.10-alt1.x86_64 init-condrestart warn /etc/rc.d/init.d/vboxweb-service: missing condrestart target. Note: alt-specific script %_sbindir/post_service (used in %post_service macro) depends on condrestart. It is wise to add condrestart anyway./etc/rc.d/init.d/vboxweb-service: missing condstop target. Note: alt-specific script %_sbindir/preun_service (used in %preun_service macro) depends on condstop. It is wise to add condstop anyway.

generated by repocop at Sun Jul 5 04:25:14 2020