Repocop reports by acl

  packager rpm id test status message
ekorneechev alterator-grub-0.13-alt1.x86_64 bin-permissions info not executable file /usr/bin/grub-bootable
not executable file /usr/bin/grub-disk
not executable file /usr/bin/grub-md-list
not executable file /usr/bin/grub-raid-boot
ekorneechev nextcloud-apache2-16.0.0-alt4.noarch altlinux-policy-obsolete-httpd2-reload info This package contains httpd2 restart/reload calls in its post/un scripts. But those calls are deprecated by httpd2.filetrigger that activates by files in /etc/httpd2/ or %_libdir/apache2/modules/. It should be safe to remove those calls and rely on the filetrigger instead.
ekorneechev nextcloud-client-2.5.2-alt2.src beehive-log-unpackaged-files-found-i586 info warning: Installed (but unpackaged) file(s) found:
/nextcloud-client.lang
/usr/include/nextcloudsync/creds/abstractcredentials.h
/usr/include/nextcloudsync/creds/httpcredentials.h
/usr/include/nextcloudsync/mirall/account.h
/usr/include/nextcloudsync/mirall/configfile.h
/usr/include/nextcloudsync/mirall/networkjobs.h
/usr/include/nextcloudsync/mirall/progressdispatcher.h
/usr/include/nextcloudsync/mirall/syncengine.h
/usr/include/nextcloudsync/mirall/syncfileitem.h
/usr/include/nextcloudsync/mirall/syncresult.h
/usr/share/applications/nextcloud.desktop
/usr/share/nemo-python/extensions/syncstate-Nextcloud.py
/usr/share/nextcloud/i18n/client_TW.qm
ekorneechev nextcloud-client-2.5.2-alt2.src beehive-log-unpackaged-files-found-x86_64 info warning: Installed (but unpackaged) file(s) found:
/nextcloud-client.lang
/usr/include/nextcloudsync/creds/abstractcredentials.h
/usr/include/nextcloudsync/creds/httpcredentials.h
/usr/include/nextcloudsync/mirall/account.h
/usr/include/nextcloudsync/mirall/configfile.h
/usr/include/nextcloudsync/mirall/networkjobs.h
/usr/include/nextcloudsync/mirall/progressdispatcher.h
/usr/include/nextcloudsync/mirall/syncengine.h
/usr/include/nextcloudsync/mirall/syncfileitem.h
/usr/include/nextcloudsync/mirall/syncresult.h
/usr/share/applications/nextcloud.desktop
/usr/share/nemo-python/extensions/syncstate-Nextcloud.py
/usr/share/nextcloud/i18n/client_TW.qm
ekorneechev nextcloud-client-2.5.2-alt2.x86_64 altlinux-policy-shared-lib-contains-devel-so info SharedLibs Policy Draft violation: Shared Lib package should not contain symlink /usr/lib64/libnextcloudsync.so but just /usr/lib64/libnextcloudsync.so.2.5.2. According to SharedLibs Policy Draft, symlink /usr/lib64/libnextcloudsync.so should be placed in a special subpackage named lib-devel. If you have already packaged this symlink in lib-devel, just append \%exclude /usr/lib64/libnextcloudsync.so to \%files of nextcloud-client-2.5.2-alt2.x86_64. Otherwise, move the symlink into the subpackage lib-devel. There is a known exception for case the .so file is not a shared lib but a plugin that is never directly linked with. Please report such a case to repocop test.
ekorneechev nextcloud-client-2.5.2-alt2.x86_64 arch-dep-package-has-big-usr-share info The package has a significant amount of architecture-independent data in /usr/share, while it is an architecture-dependent package. This is wasteful of mirror space and bandwidth, as we then end up with multiple copies of this data, one for each architecture. If the data in /usr/share is not architecture-independent, it is a policy violation, and in this case, you should move that data elsewhere.
ekorneechev nextcloud-client-2.5.2-alt2.x86_64 rpm-obsolete-live-package info The package obsoletes the package mirall-1.0.2-alt6.x86_64, but the package mirall-1.0.2-alt6.x86_64 is still alive and in the repository. Ask its maintainer to remove it, or, if it should not be removed, remove the Obsoletes: tag. Do not forget to add explicit conflicts with the other package if nessessary.
ekorneechev pinta-1.6-alt5.x86_64 iconsdir experimental Please, move pixmaps from /usr/share/pixmaps to %_liconsdir, %_niconsdir, %_miconsdir according to their size. See http://www.altlinux.org/IconPathsPolicy.
ekorneechev python-module-secretstorage-2.3.1-alt1.src altlinux-python-obsolete-buildreq-python-dev warn python-dev is obsolete according to Python Policy (http://www.altlinux.org/Python_Policy). Please, use BuildRequires: python-devel.
ekorneechev vino-mate-3.8.1-alt4.x86_64 file-in-usr-marked-as-conffile warn Files below /usr may not be marked as conffiles, since
/usr might be mounted read-only and thus, the local system
administrator would not have a chance to modify this configuration
file.
ekorneechev vino-mate-3.8.1-alt4.x86_64 freedesktop-desktop info desktop-file-validate utility printed the following message(s): /usr/share/applications/vino-preferences.desktop: hint: value "GNOME;GTK;Settings;X-GNOME-NetworkSettings;RemoteAccess;Network;" for key "Categories" in group "Desktop Entry" contains more than one main category; application might appear more than once in the application menu
ekorneechev x11vnc-service-0.2-alt1.noarch missing-url info Missing Url: in a package.
ekorneechev x11vnc-service-0.2-alt1.noarch systemd-but-no-native-init warn The package have native systemd file(s) but no SysV init scripts.

generated by repocop at Wed Nov 13 04:41:16 2019